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Getting Started with the eBUS-PureGEV 
Package

The eBUS-PureGEV Package is a complete set of tools for configuring and controlling your GigE 
Vision enabled camera. GEVPlayer is a simple and powerful program that allows you to capture your 
first images with your IP Engine quickly. Then, as you familiarize yourself with GigE Vision, you can 
create your own application with the optional SDKs.

The eBUS-PureGEV Package lets you quickly take your GigE Vision device from concept to prototype 
to finished product.

In this section:
Getting started.............................................................................................................. 1
Going further................................................................................................................ 1

Getting started

To acquire your first images using the eBUS-PureGEV Package:
1. Insert your software CD in your PC and install the eBUS-PureGEV Package. During this step, you 

will install the NIC driver that best meets your needs. (The iPORT PureGEV Suite requires an 
eBUS driver.)

2. Cable your camera, IP Engine, and PC together. See “Cabling Your Camera to the PC” on page 7.
3. If you’re using Windows XP, configure the firewall. See “Configuring the Windows XP Firewall” 

on page 13.
4. Launch GEVPlayer. See “Launching GEVPlayer” on page 19.
5. Connect to your IP Engine. See “Connecting to your IP Engine” on page 21.
6. Acquire your first images. See “Acquiring images” on page 23.

Going further...
Once you’ve acquired your first images, you can:

• Configure and control your IP Engine further. See “Controlling your IP Engine” on page 25.
• Track the performance of your camera, IP Engine, and PC. See “Tracking performance” on 

page 29.
• Write your own program! See “Creating your own GigE Vision system” on page 31.
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Understanding the iPORT PureGEV Suite

In this section:
About IP Engines, cameras, and GEV devices ............................................................ 3
The birth of GigE Vision ............................................................................................. 4

About IP Engines, cameras, and GEV devices
Though the iPORT PureGEV Suite is principally designed to support iPORT IP Engines (with GEV 
firmware), you can also use it to connect to and control third-party GEV devices. By necessity, the doc-
umentation distinguishes the IP Engine and the camera you’re (typically) integrating. 

However, the form factor of your IP Engine can vary. The form of your IP Engine could be a standalone 
IP Engine, a standalone IP Engine with a separate cable-connected camera, an IP Engine and camera 
integrated into a single physical unit, or a third-party GigE Vision compliant camera.

IP Engine CameraCamera

IP EnginePC

CameraIP Engine

Brand X GigE Vision device

The iPORT PureGEV Suite lets you connect to any GigE Vision compliant device, regardless of its 
form!

IP Engine CameraCamera

IP EnginePC

CameraIP Engine

Brand X GigE Vision device
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The birth of GigE Vision
Ideally, knowing how to set a parameter on one camera...

PC
IP Engine Camera

CameraIP Engine

CameraIP Engine

gain 42

...would let you make the same setting for all cameras.

PC
IP Engine Camera

CameraIP Engine

CameraIP Engine

gain=42

gain=42

gain=42

However, cameras have manufacturer-specific or model-specific instruction sets.

PC
IP Engine Camera

CameraIP Engine

CameraIP Engine

Huh?

什麼？

Vadå?

As a result, end users, programmers, or someone had to adapt for every camera they used.

PC
IP Engine Camera

CameraIP Engine

CameraIP EngineFörstärkning=42

增益=42

set amp 2Ah
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To reduce frustration, Pleora created camera-specific DLLs for as many models as they could (in the 
iPORT Vision Suite). These DLLs helped provide a more standard interface. Though the process was 
time-consuming (for Pleora), the DLLs worked well...

PC
IP Engine Camera

CameraIP Engine

CameraIP Engine

gain=42

gain=42

gain=42 Förstärkning=42

增益=42

set amp 2Ah

...unless something changed.

PC
IP Engine CameraCamera

CameraIP Engine

CameraIP Engine

什麼？

Recognizing that the increasing complexity of modern cameras would exacerbate end-user frustration 
(and that keeping all DLLs up-to-date was impossible), Pleora and a group of companies created the 
GigE Vision Standard. To be compliant, a GigE Vision device has to provide an XML file that defines 
its features and how to use them.

XML

Using an iPORT IP Engine and a camera together, you can create a system that behaves as a single, 
GEV-compliant device. The IP Engine stores the XML file and provides it on request (as well as 
providing the required GEV interface).

PC
Camera

Camera

Camera

IP Engine

IP Engine

IP Engine

CameraCamera

XML
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Cabling Your Camera to the PC

When it comes to cabling, your iPORT IP Engine gives you a lot of flexibility. However, if you’re 
cabling it for the first time, we recommend that you make a dedicated connection between your IP 
Engine and PC.

To cable your camera to your PC:
• Cable your system as described in either “Dedicated connection” on page 7 or “Dedicated 

connection with a second regular NIC” on page 7. Power cables aren’t shown.

Dedicated connection
If you require a very high bandwidth connection to your IP Engine but don’t require corporate network 
connectivity, use the configuration below.

PC

IP EngineCamera NIC

Ethernet cable
Video cable

For best performance,
use Intel PRO/1000 NIC

This configuration might be used for a standalone machine vision system. For best performance, cable 
your IP Engine to an Intel PRO/1000 NIC. The Intel PRO/1000 NIC is reliable and lets you use the 
efficient eBUS Optimal Driver.

Dedicated connection with a second regular NIC
If you intend to use your NIC as a dedicated connection to your camera, use the configuration below. In 
this configuration, you have a second NIC for corporate network connectivity.

PC

IP EngineCamera NIC

To office network
and Internet NIC
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Switched connection (not recommended for first-time use)
If you intend to use a single NIC for both the connection to your camera and corporate network connec-
tivity, use the configuration below.

PC

IP EngineCamera NIC
Switch

To office network
and Internet

If you’re setting up your IP Engine for the first time, we advise against using this configuration. Such an 
arrangement can cause the following problems:

• You can experience data loss, delay, or network slowdowns if the switch employs blocking 
architecture or insufficient packet forwarding capability.

• You can experience connectivity problems due to a switch that is nonstandard or improperly 
configured (jumbo frames not enabled).

• Switches that use a spanning tree algorithm often incur a significant delay (several minutes) 
when establishing a connection between a PC and the IP Engine. We recommend that you turn 
off spanning tree implementations on the switch (check with your network administrator).
Copyright © 2009 Pleora Technologies Inc.
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Understanding Drivers

In this section:
Quick pick.................................................................................................................... 9
Understanding drivers.................................................................................................. 9
Choosing your driver ................................................................................................. 10

Quick pick
In general, the eBUS Universal Driver is a good, all-round choice.

Understanding drivers
A regular manufacturer’s NIC driver receives Ethernet packets and passes them on to the Windows 
network stack. The network stack analyzes the headers from each layer.

However, for each packet, the network stack can have to perform hundreds of tests before routing the 
packet. The many decisions incur a heavy CPU usage penalty. The job of analyzing incoming packets 
overwhelms the CPU long before data throughput reaches the NIC’s potential.

PC
Data in

CPU
usage

for
packets

CPU
available
for other
purposes

Bandwidth

Slow
down!

Regular NIC driver performance

A Pleora driver tests only for data destined for your application. If so, the data bypasses the network 
stack to efficiently route data to your application. If not, the packet is sent to the Windows network 
stack. Since the great majority of the data will be for your high-bandwidth application, Pleora drivers 
dramatically reduce CPU usage. By eliminating the CPU usage bottleneck, data throughput is 
maximized and your CPU is free to perform other duties.

PC
Data in

CPU
usage

for
packets

CPU
available
for other
purposes

Bandwidth

eBUS driver performance
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Choosing your driver
Pleora offers two eBUS drivers. If you’re using an Intel PRO/1000 network card, we recommend the 
eBUS Optimal Driver. Otherwise, use the eBUS Universal Driver. If you’ve already got a project in 
development, you can use continue to use the iPORT High-Performance IP Device Driver.

Comparison of Pleora NIC Drivers

Category eBUS Optimal 
Driver

eBUS Universal 
Driver

iPORT High-Perfor-
mance IP Device 
Drivera

Manufacturer’s NIC 
driver

Efficiency

Usage High bandwidth, CPU-
intensive applications

High bandwidth appli-
cations that can tolerate 
some sharing of CPU 
capacity

Existing projects 
requiring high-band-
width

Temporary

Works with
eBUS-PureGEV 
Package

Yes Yes No No

Works with
eBUS-Vision Package

Yes Yes Yes Yes

Limitations Requires Intel PRO/
1000 NIC and 825xx 
chips

Requires Intel PRO/
1000 NIC and 825xx 
chips
No support for corpo-
rate office connectivity 
(Internet)

To upgrade... Good choice – no 
change required

Good choice – no 
change required

Replace with eBUS 
Optimal Driver

Replace with eBUS 
Universal Driver

eBUS Optimal Driver
The eBUS Optimal Driver is our recommended driver for demanding applications. The driver is a 
purpose-built replacement for the regular driver that comes with your Intel PRO/1000 card or 825xx 
chip. Designed to maximize throughput and minimize CPU usage, it’s ideal for high-bandwidth applica-
tions that need virtually all the CPU for other tasks. It also supports corporate network connectivity.

eBUS Universal Driver
The eBUS Universal Driver replaces the CPU-intensive Windows network stack. It works with almost 
any NIC because it works in conjunction with your NIC manufacturer’s driver. The eBUS Universal 
Driver supports corporate network connectivity.

iPORT High-Performance IP Device Driver
If you’re upgrading your iPORT SDK, already have an existing project under development, and you 
don’t require a GigE Vision compliant connection, we recommend that you continue using the iPORT 
High-Performance IP Device Driver – it has a solid track record of field-proven reliability. In short, if 
your current system is working well, there’s no need to change.

The iPORT High-Performance IP Device Driver is extremely efficient but disregards regular Internet 
traffic. As a result, it doesn’t support corporate network connectivity.

If you wish to upgrade, consider the eBUS Optimal Driver. 

a. The iPORT High-Performance IP Device Driver isn’t available with the eBUS-PureGEV Package. If you’re migrating to the eBUS-PureGEV 
Package or wish to use the same driver for all your products, use an eBUS driver.
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Manufacturer’s NIC driver
The manufacturer’s NIC driver is the default driver that comes with your NIC.

Your manufacturer’s NIC driver routes data through the Windows network stack. Though suitable for 
bandwidths of 100 Mb/s or less, higher bandwidths incur a significant CPU usage penalty. Bandwidth is 
limited when CPU usage reaches 100%. By devoting all its resources to packet routing, the PC is left 
with insufficient CPU resources for other tasks (such as processing or displaying images).
Copyright © 2009 Pleora Technologies Inc.
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Configuring the Windows XP Firewall

In its default configuration, the Windows XP Firewall can block certain network packets between your 
IP Engine and your image-acquisition program (e.g. Coyote, GEVPlayer, or your own program).

Follow the directions to ensure Windows XP Firewall lets your programs work as you expect. Finally, 
and only if you prefer, you can use the directions to disable the firewall completely.

If you’re using Windows Vista, you don’t need to make any changes.

To configure the Windows XP Firewall:
1. From the Windows Start menu, select Start > Control Panel.

The Control Panel appears.
2. Open the Windows Firewall.

If the firewall is set to Off (such as for closed systems), no further changes are required.
3. On the General tab, allow exceptions (Uncheck Don’t allow exceptions).
4. Select the Exceptions tab.
5. Click Add Program.

The Add a Program dialog appears.
6. Select your program (e.g. Coyote, GEVPlayer, or your own program) and click OK.

The Add a Program dialog closes and your program appears in the Programs and Services field.
7. Click OK to close the Windows Firewall dialog.

The Windows XP Firewall now allows your program to send and receive network packets. 
Copyright © 2009 Pleora Technologies Inc.
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Configuring your NIC

If you’re in a typical networked office environment, your NIC will get its IP address from a DHCP 
server. However, if you’re setting up for the first time, we recommend that you make a direct connection 
to your iPORT IP Engine. Without a DHCP server, Windows uses Zeroconf (also known as Autoconf or 
LLA fallback), but the fallback takes up to a minute every time you disconnect.

To connect faster, you can configure a static IP address. See “Dedicated connection (static IP address)” 
on page 15.

If you want to configure your NIC to get its IP address from a DHCP server, see “Multi-use connection 
(DHCP server)” on page 16.

Dedicated connection (static IP address)
This configuration assigns your NIC a static IP address. 

To configure your NIC for a dedicated connection:
1. Make the following selections:

In Windows XP: From the Windows Start menu, select Start > Control Panel > Network 
Connections.
In Windows Vista: From the Windows Start menu, select Start > Control Panel > Network 
and Sharing Center > Manage Network Connections.

2. Right-click your Local Area Connection and select Properties.
The Local Area Connection Properties dialog appears.

3. Make the following settings:
Client for Microsoft Networks

File and Printer Sharing for Microsoft Networks

QoS Packet Scheduler
Copyright © 2009 Pleora Technologies Inc.
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4. Select Internet Protocol (TCP/IP) and click Properties.
The Internet Protocol (TCP/IP) Properties dialog appears.

5. Enable Use the following IP address and make the following settings:
IP address 192.168.101.001
Subnet mask 255.255.255.0
Default gateway leave blank

Ensure you’re not conflicting with an existing IP address on another NIC. For multiple dedicated 
connections on the same host PC, increment the third IP address by one for each NIC (i.e. 101, 102, 
103, etc.).

6. Click OK to close the Internet Protocol (TCP/IP) Properties dialog.
7. Click Close to close the Local Area Connection Properties dialog.

Your NIC is now configured for a dedicated connection. When you cable your NIC to another NIC, 
Windows will recognize the connection without any delay.

Multi-use connection (DHCP server)
If you’re using your NIC for both your eBUS data and your regular office network connectivity, 
configure it as a multi-use connection. This configuration is generic and presumes your office network 
uses a DHCP server. For the exact settings for your network, consult with your company’s IT 
department.

To configure your NIC for a multi-use connection:
1. From the Windows Start menu, select Start > Control Panel.

The Control Panel dialog appears.
2. Double-click Network Connections.

The Network Connections dialog appears.

Internet Protocol (TCP/IP)

Show icon in notification area when connected

Notify me when this connection has limited or no connectivity
Copyright © 2009 Pleora Technologies Inc.
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3. Right-click your Local Area Connection and select Properties.
The Local Area Connection Properties dialog appears.

4. Make the following settings:
Client for Microsoft Networks

File and Printer Sharing for Microsoft Networks

QoS Packet Scheduler

Internet Protocol (TCP/IP)

Show icon in notification are when connected

Notify me when this connection has limited or no connectivity

 

5. Select Internet Protocol (TCP/IP) and click Properties.
The Internet Protocol (TCP/IP) Properties dialog appears.

6. Enable Obtain an IP address automatically.
7. Enable Obtain DNS server address automatically.
8. Click OK to close the Internet Protocol (TCP/IP) Properties dialog.
9. Click Close to close the Local Area Connection Properties dialog.

Your NIC will now get its IP address from a DHCP server.
Copyright © 2009 Pleora Technologies Inc.
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Launching GEVPlayer

To launch GEVPlayer:
• From the Windows Start menu, select Start > All Programs > Pleora Technologies Inc > eBUS-

PureGEV Package > GEVPlayer.
The main page of GEVPlayer appears. You can now connect to your IP Engine. See “Connecting to 
your IP Engine” on page 21.

Understanding GEVPlayer
GEVPlayer consists of two parts — the control side and the display side.

The control side (on the left) lets you select and connect to an IP Engine, configure it, and acquire 
images. The display side (on the right) passively displays images from your IP Engine.

left side - control right side - display
Copyright © 2009 Pleora Technologies Inc.
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Connecting to your IP Engine

To select and connect to your IP Engine:
1. Launch GEVPlayer. See “Launching GEVPlayer” on page 19.

2. In the Connection pane, click Select / Connect.
The GEV Device Selection dialog appears, listing the IP Engines that each NIC found. NICs 
connected to a switched network may find multiple IP Engines.

3. Check Show unreachable GigE Vision Devices.
4. In the Available IP Engines pane, select your IP Engine.

GEVPlayer displays information about your selection in the IP Engine and NIC information 
pane.
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22   Connecting to your IP Engine
5. Click Set IP Address.
The Set IP Engine IP Address dialog appears.

6. In the IP Engine Settings pane, enter the IP Address, Subnet Mask, Gateway.
7. Click OK.

The Set IP Engine IP Address dialog closes.

8. Click OK.
The GEV Device Selection dialog closes and GEVPlayer connects to your IP Engine. You can now 
acquire images. See “Acquiring images” on page 23.
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Acquiring images

The Acquisition Control pane lets you easily access the features that control how you acquire images.

The GigE Vision Standard requires that your IP Engine start up in a state ready to send images. In fact, 
you can still acquire images even if you don’t have a camera — iPORT IP Engines send a sawtooth-
shaped test pattern by default.

To acquire images:
1. Select and connect to your IP Engine. See “Connecting to your IP Engine” on page 21.
2. In the Acquisition Control pane, select your preferred Mode and Channel. For continuous 

images, select Continuous and Data Channel #0. For other acquisition modes, see “Understand-
ing acquisition modes” on page 24.

3. In the Acquisition Control pane, click Play.
The images appear in the Display pane. If you want to control the IP Engine further see “Control-
ling your IP Engine” on page 25.

4. If you want to zoom the image in or out, right-click the image and select a zoom setting from the 
context menu.

5. If you want to adjust the image’s color, select Tools > Image Filtering.

6. If you want to save one image (or many), select Tools > Save images.
7. If you want to save the settings for GEVPlayer and your IP Engine to disk, select File > Save.
Copyright © 2009 Pleora Technologies Inc.
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Understanding acquisition modes
Your IP Engine lets you acquire images continuously, or frame-by-frame. You can also save images to 
the IP Engine’s onboard memory and retrieve them later. The IP Engine’s acquisition modes include:

Continuous
Acquire images continuously.

ContinuousReadout
Acquire images continuously from the IP Engine’s onboard memory (until all images in 
memory have been retrieved).

ContinuousRecording
Save images to the IP Engine’s onboard memory until its memory is full. 

Multiframe
Acquire a fixed number of images. To configure the number of images, set the IP Engine’s 
AcquisitionFrameCount feature.

SingleFrame
Acquire a single image.

SingleFrameReadout
Acquire a single image from the IP Engine’s onboard memory.

SingleFrameRecording
Save a single image to the IP Engine’s onboard memory.
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Controlling your IP Engine

GEVPlayer lets you control settings using three functionally identical dialogs.

Control dialogs
Dialog name Button Purpose
Communication Control
dialog

Controls network transport layer 
settings

GEV Device Control
dialog

Controls settings on the IP Engine 
and camera

Image Stream Control
dialog 

Controls image stream settings 
and provides performance statis-
tics

To access the control dialogs:
• In the Parameters and Controls pane, click one of: GEV Device control, Communication 

control, or Image stream control.
A control dialog appears.

Understanding the control dialogs

To control the list of features in the left-hand pane:
• Expand and collapse the tree by clicking the + and - icons.

• Find features alphabetically by using the alphabetization button .
• To show all features, set Visibility to Guru; to hide complex features, set Visibility to Beginner. 

To control features:
1. Select a feature in the left-hand column.

Information about the feature appears in the bottom pane. 
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2. If the feature has an editable value, change the value in the edit window. The value is applied when 
you click somewhere else.

3. If the feature is a command, click it to make the button appear. Click the button to activate the 
command.

Understanding the controls
All the IP Engine’s features are parameter based. By changing the value of a feature, you can directly 
control how the IP Engine works. In fact, most of the information in GEVPlayer directly correlates to a 
parameter-based feature in the IP Engine.
Copyright © 2009 Pleora Technologies Inc.
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Connection pane
Features in the Connection pane
Connection pane 
shortcut IP Engine feature

IP address field GigEVisionTransportLayer > GevCurrentIPAddress
MAC address field GigEVisionTransportLayer > GevMACAddress
Manufacturer field DeviceInformation > DeviceVendorName
Model field DeviceInformation > DeviceModelName

 

Acquisition Control pane
Features in the Acquisition Control pane
Acquisition Control 
pane shortcut IP Engine feature

Mode dropdown AcquisitionAndTriggerControls > AcquisitionMode
Channel dropdown GigEVisionTransportLayer > GevStreamChannelSelector
Play button AcquisitionAndTriggerControls > AcquisitionStart
Stop button AcquisitionAndTriggerControls > AcquisitionStop
Copyright © 2009 Pleora Technologies Inc.
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Display pane
Features in the Display pane
Display pane short-
cut Image stream feature

Image count 
(e.g. nnn images)

Statistics > General > ImagesCount

Frame rate 
(e.g. xxx FPS)

Statistics > General > AcquisitionRateAverage

Data rate 
(e.g. yyy Mbps)

Statistics > General > BandwidthAverage
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Tracking performance

As your IP Engine receives images from your camera and sends them to your PC, it keeps track of 
image errors (missing lines, etc.), network errors (lost packets, etc.), and other performance-related 
statistics.

To track performance:
• See a complete list of error counts in the Image Stream Control dialog. Performance metrics are 

grouped in the Statistics folder.

• See a summarized list at the bottom of the Display pane. The pane shows the total number of 
images displayed (ImagesCount), the instantaneous frame rate (AcquisitionRateAverage), and 
the data rate (BandwidthAverage).
Copyright © 2009 Pleora Technologies Inc.
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Creating your own GigE Vision system

Now that you’ve successfully connected to your IP Engine and acquired your first images, you’re ready 
to begin developing your own system!

In this section:
Customizing your software ........................................................................................ 31

Customizing your software
For customizing your software, GEVPlayer is a good place to start — not only is it a complete applica-
tion, it was designed specifically to be a sample that you can use as a template for your own application!

To customize your software:
1. Configure your IDE (integrated development environment). See the “Creating a new C/C++ 

project” section in the iPORT PureGEV C++ SDK Reference Guide.
2. Copy the PVSimpleUI code as a new project. To browse the PVSimpleUI code (and all other 

samples), from the Windows Start menu, select Start > All Programs > Pleora Technologies 
Inc > eBUS-PureGEV Package > Code Samples.

3. Use the PVSimpleUI code as a template for your own program. You can also use the goal-oriented 
procedures in the iPORT PureGEV C++ SDK Reference Guide.
Copyright © 2009 Pleora Technologies Inc.
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Modifying Camera Parameters

Serial Communication

Introduction
You might want to bypass the standard GigE Vision configuration of your camera with a Pleora IP 
Engine, and modify camera parameters through the serial ports, UART0 and UART1 for your specific 
vision application.

PureGEV allows you to control Serial Port 0 and Serial Port 1 (UART0 and UART1, respectively) of a 
GigE Vision Device that is integrated with a Pleora IP Engine. Typically, Serial Port 0 is mapped to the 
camera head of the device and Serial Port 1 can control or monitor lighting systems and motion control 
systems.

These serial ports are physically implemented on the device and can be accessed through the GVCP link 
managed by a PvDevice, that allows you to connect to and control your GigE Vision device. The Serial 
Communication Link is shown in the figure below.

PC GVCP iPORT

Serial Tx

Serial Rx

“Virtual” Serial Link

Serial Device
Typically CL Camera Head

Consult the Pleora IP Engine hardware guide specific to your application for more information on serial 
ports.

Assumptions
Before attempting to modify camera parameters through the serial ports, you must be familiar with 
these topics:

• “Launching GEVPlayer” on page 19 in this quick start guide
• “Connecting to your IP Engine” on page 21 in this quick start guide
• “Acquiring images” on page 23 in this quick start guide
• “Controlling your IP Engine” on page 25 in this quick start guide
• The hardware guide specific to your IP Engine
Copyright © 2009 Pleora Technologies Inc.



34   Modifying Camera Parameters
Accessing the Serial Ports
You must successfully connect to the camera integrated with the IP Engine core with GEV Player to 
write (Tx) to a serial port, or control and monitor incoming data (Rx) of various formats.

Before selecting the serial ports for data transmit and receive, you must set the baud rate for the serial 
ports, if the default value is not acceptable.

NOTE! You must determine the baud rate values for both Serial Port 0 and Serial Port 1 for successful 
data transmit and receive. These values are set by the Uart0BaudRate and 
Uart1BaudRate parameters through the GEV Device Control button in the GEVPlayer 
application.

To set the baud rate for the serial ports.
1. Click the GEV Device Control button in the GEV Player main Window.

The Device Control Window appears.
Copyright © 2009 Pleora Technologies Inc.
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2. Set the baud rate parameter, Uart0BaudRate for Serial Port 0 (UART0).
3. Set the baud rate parameter, Uart1BaudRate for Serial Port 1 (UART1), if enabled.

Selecting the Serial Ports
To access the serial ports with the GEV Player application.
1. Launch GEV Player from the desktop, or alternately in the Menu Bar,

Click Start> All Programs> Pleora Technologies Inc> eBUS-PureGEV Package> GEVPlayer

The GeVPlayer application splash appears.

2. In the GEV Player Menu Bar, click Tools> IP Engine Serial Communication....
Copyright © 2009 Pleora Technologies Inc.



36   Modifying Camera Parameters
The IP Engine Serial Communication Window appears.

3. In the Port Selection group, select Serial0 or Serial1 from the pull-down.
Copyright © 2009 Pleora Technologies Inc.



37
Setting the Transmit Data Sequence
You must determine the correct data sequence and format before transmitting data over the serial ports.
1. In the Send group, select the transmit data sequence format, ASCII (text only), or Hexadecimal. 

For Hexadecimal, enter a pair of  hexadecimal digits for each byte, separated by spaces.

2. Enter the data string in the Data field.
3. Click any of CR, LF, NULL, or Other as trailer options (Append). Trailer options are not 

mutually exclusive; they are appended in the order shown. Select Other for ASCII and 
hexadecimal sequences in custom trailers for camera heads that do not use the trailer options in the 
order shown (for example, CR and LF).

4. Click Send to transmit the data sequence.

Receiving Data
Data that is received over the serial port is displayed in the Transcript group in the IP Engine Serial 
Communication Window.

1. Select ASCII, Hexadecimal, or Hybrid to determine the format for the displayed data.
2. Click Clear to clear the Transcript data pane.

NOTE! The Hybrid option is selected for data that is comprised of both binary protocol and ASCII 
strings. It might be necessary to view binary terminators in an ASCII string, or ASCII string 
attributes in binary data. For example, in an ASCII string you cannot see the 0x07 end-of-line 
(EOL) binary terminator; conversely, in binary protocol you cannot see the “set width=640” 
attribute string. Selecting the Hybrid option allows you to view both formats at the same time.
Copyright © 2009 Pleora Technologies Inc.



38   Modifying Camera Parameters
Serial Ports and the SDK
You can create your own GigE Vision application and use the PvSerialPortIPEngine class in the 
SDK to access a Pleora IP Engine serial port. Configure the Class object with the Open method by 
providing a pointer to the serial port of the PvDevice that is already connected. Use the Read and Write 
methods to write and read data, to and from the port.

Use the PvTerminalIPEngineWnd class to display the same serial port terminal dialog GEVPlayer 
is using in your application. Then, use the ShowModal method to display the dialog.

NOTE! Use caution to access the IP Engine camera head directly through the serial port. If the port is 
open, all GenICam parameters of the device linked to the camera head are not functional. In 
addition, it is possible for the GenICam cache for these parameters to lose synchronization 
with the camera head and the IP Engine.
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Technical support 

If you’re having problems, the first place to look is in the accompanying documentation. In particular, 
the iPORT Concepts Guide explains many topics that have been traditional trouble spots for our 
customers. The following are good sources of additional information and help. For best results, please 
read the entire section before deciding how to proceed.

Camera Documentation
Cameras are complicated devices with many settings and features; many image-acquisition troubles are 
actually a misconfiguration or a working camera awaiting a trigger signal. For additional information, 
consult the documentation that accompanied your camera.
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